"Joe Sam Shirah" <jshirah@xxxxxxxxxxxxx> wrote:
Sounds like one of those premature optimization things.
Not really; it's just that the intern() had been there for quite a while, whereas the truncation (and the need for it) is a comparatively recent change. And until I actually looked it up, I wasn't even aware of what intern() does (I wasn't the one who put it there).
This mailing list archive is Copyright 1997-2013 by MIDRANGE dot COM and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available here. If you have questions about this, please contact