× The internal search function is temporarily non-functional. The current search engine is no longer viable and we are researching alternatives.
As a stop gap measure, we are using Google's custom search engine service.
If you know of an easy to use, open source, search engine ... please contact support@midrange.com.



Hi Jon -

On Thu, 13 Dec 2007 09:07:36 -0500, Jon Paris
<Jon.Paris@xxxxxxxxxxxxxx> wrote:

On 13-Dec-07, at 6:22 AM, Ken Sims wrote:

As I
was putting the array index on the statements loading the various
sub-fields, I thought "Why the hell am I doing this? I'm not going to
be sorting it or doing anything else which needs the array
functionality."

I can tell you why I would have done it - because it would make it
obvious to those reading the code later (me included) _exactly_ which
value (from the set represented by the array/MODS) was being used by
the instruction. That simple piece of knowledge - which would save
me time over and over again in the future - far outweighs any trivial
benefit from the few seconds I saved by not having to type the
subscript.

For example if using a DS for before/after images of a record and I
see this code:

If myRecord(before).custType = retail;

I know exactly which field is being referenced. Which one is this
referencing?

If custType = retail;

To me it is that simple.

In programming I don't want to use new features simply because they
are new, but if - as in this case - they offer significant
improvements in readability then I think adoption of the new
technique is the right way to go.

In the programming that I do, the overwhelming majority of the time in
data structures which have more than one occurrence, no particular
occurrence is any different than any other occurrence. The same field
is use for referencing all occurrences, just a generic unsigned
integer field.

If myRecord(x).custType = retail;

doesn't tell me anything special about that occurrence of the data
structure, and rightly so, because there _is_ nothing special about
that occurrence of the data structure.

When I have a before data structure and an after data structure, I
make them separate single occurrence data structures and define one in
terms of the other or both in terms of a record format.

I think

If beforeRecord.custType = retail;

is just as clear as

If myRecord(before).custType = retail;

Ken
Opinions expressed are my own and do not necessarily represent the views
of my employer or anyone in their right mind.

As an Amazon Associate we earn from qualifying purchases.

This thread ...


Follow On AppleNews
Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2024 by midrange.com and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available on our policy page. If you have questions about this, please contact [javascript protected email address].

Operating expenses for this site are earned using the Amazon Associate program and Google Adsense.