MIDRANGE dot COM Mailing List Archive



Home » MIDRANGE-L » January 2013

Re: http configuration confusion.



fixed

ok, if you do a wrklnk www, can you drill down into your server instance
and see any log files.

On Thu, Jan 10, 2013 at 10:33 AM, Smith, Mike
<Mike_Smith@xxxxxxxxxxxxxxxx>wrote:

It appears logging is turned on from what I see.

If I type in http://rgt:1080 I get a sampe page for http server REDIRECT

-----Original Message-----
From: midrange-l-bounces@xxxxxxxxxxxx [mailto:
midrange-l-bounces@xxxxxxxxxxxx] On Behalf Of Jack Kingsley
Sent: Thursday, January 10, 2013 10:27 AM
To: Midrange Systems Technical Discussion
Subject: Re: http configuration confusion.

You might want to turn logging on, also if you just type in
http://rgt:1080

what do you get.


On Thu, Jan 10, 2013 at 10:10 AM, Smith, Mike
<Mike_Smith@xxxxxxxxxxxxxxxx>wrote:

Sean
I tried your suggestion and got the same results.

SO, this is what I have done now, with the hopes that I've made it
simpler to resolve the problem.
I created a new HTTP Server instance using the wizard and named it
REDIRECT . Here is my configuration.

1 # Configuration originally created by Create HTTP Server wizard on
Thu Jan 10 09:25:54 EST 2013
2 Listen *:1080
3 DocumentRoot /www/redirect/htdocs
4 TraceEnable Off
5 Options -ExecCGI -FollowSymLinks -SymLinksIfOwnerMatch -Includes
-IncludesNoExec -Indexes -MultiViews
6 LogFormat "%h %T %l %u %t \"%r\" %>s %b \"%{Referer}i\"
\"%{User-Agent}i\"" combined
7 LogFormat "%{Cookie}n \"%r\" %t" cookie
8 LogFormat "%{User-agent}i" agent
9 LogFormat "%{Referer}i -> %U" referer
10 LogFormat "%h %l %u %t \"%r\" %>s %b" common
11 CustomLog logs/access_log combined
12 LogMaint logs/access_log 7 0
13 LogMaint logs/error_log 7 0
14 AccessFileName .htaccess
15 SetEnvIf "User-Agent" "Mozilla/2" nokeepalive
16 SetEnvIf "User-Agent" "JDK/1\.0" force-response-1.0
17 SetEnvIf "User-Agent" "Java/1\.0" force-response-1.0
18 SetEnvIf "User-Agent" "RealPlayer 4\.0" force-response-1.0
19 SetEnvIf "User-Agent" "MSIE 4\.0b2;" nokeepalive
20 SetEnvIf "User-Agent" "MSIE 4\.0b2;" force-response-1.0
21 DirectoryIndex index.html
22 <Directory />
23 Order Deny,Allow
24 Deny From all
25 </Directory>
26 <Directory /www/redirect/htdocs>
27 Order Allow,Deny
28 Allow From all
29 </Directory>
30 ScriptAlias /redir /QSYS.LIB/TSTMIS.LIB/REDIR.PGM
31 <Directory /QSYS.LIB/TSTMIS.LIB>
32 order deny,allow
33 </Directory>

I recompiled the programs in library TSTMIS changing the QCMDEXC to
look like this QCMDEXC('STRPCCMD PCCMD(''rundll32
url,FileProtocolHandler '
+ 'http://rgt:1080/redir.pgm?' + %char(Key)
+ ''') PAUSE(*NO)' : 200);

Now I run openurl and I still get the same Browser url shows
http://rgt:1080/redir.pgm?15 There is no log file generated and the
program REDIR is not being called.

Where do I go come here?

Thanks

MIke

-----Original Message-----
From: midrange-l-bounces@xxxxxxxxxxxx [mailto:
midrange-l-bounces@xxxxxxxxxxxx] On Behalf Of Porterfield, Sean
Sent: Wednesday, January 09, 2013 5:07 PM
To: Midrange Systems Technical Discussion
Subject: RE: http configuration confusion.

Your original example: http://rgt:8014/rgcgip/vendprof.pgm
Your new code: http://rgt:8014/rgcgip/redir?7

I don't know how you have it configured, but if it's the same,
shouldn't that second one be http://rgt:8014/rgcgip/redir.pgm?7 ?
--
Sean Porterfield


-----Original Message-----
From: midrange-l-bounces@xxxxxxxxxxxx [mailto:
midrange-l-bounces@xxxxxxxxxxxx] On Behalf Of Smith, Mike
Sent: Wednesday, January 09, 2013 16:40
To: 'Midrange Systems Technical Discussion'
Subject: RE: http configuration confusion.

Ok, so I removed the <i> and </i> stopped and restarted the http server.

So I run OPENURL and the browser displays
http://rgt:8014/rgcgip/redir?7 number changes after each time I run
This gives me the 404 page not found.

I haven't located the log files yet.

I know REDIR hasn't run as the last used date is blank, so for now I
don't think I need the DSPLY.

Mike

-----Original Message-----
From: midrange-l-bounces@xxxxxxxxxxxx [mailto:
midrange-l-bounces@xxxxxxxxxxxx] On Behalf Of Mike Krebs
Sent: Wednesday, January 09, 2013 4:05 PM
To: Midrange Systems Technical Discussion
Subject: Re: http configuration confusion.

When you set up the script alias - you took out the <i> and </i> right?
And you restarted the instance of the HTTP server?

If you run http://rgt:8014/rgcgip/redir?12345 directly in the browser,
does it appear to do anything?

stick a DSPLY in REDIR to see if it gets there. The message should
appear in QSYSOPR.

Check the log files in the IFS whereever they are configured to be.
Ours are in '/www/intranet1/logs'


The URL of the page not found page? Is it REDIR or is it the other?

Start a wireshark trace and see what you are sending and receiving
directly



________________________________
From: "Smith, Mike" <Mike_Smith@xxxxxxxxxxxxxxxx>
To: "Midrange Systems Technical Discussion (midrange-l@xxxxxxxxxxxx)"
< midrange-l@xxxxxxxxxxxx>
Sent: Wednesday, January 9, 2013 2:33 PM
Subject: FW: http configuration confusion.

Due to the length restrictions of the STRPCCMD, I am looking at
alternatives to serving URL from my I. I ran across this article from
Scott Klement from 2007

http://www.iprodeveloper.com/article/rpg-programming/use-cgi-redirects
-to-launch-long-urls-18117

I'm trying to get this working to see if this will work for our needs.
However, I really don't know anything about HTTP configuration. It
might as well be greek.

That said many years ago I did create a couple of CGIDEV2 programs
that work. So I placed the ScriptAlias stuff in the same http
instance at the very bottom.
I created the programs associated with this in the same library as my
CGIDEV2 programs.

When I run my CGIDEV2 programs from the browser, I call
http://rgt:8014/rgcgip/vendprof.pgm

SO in the openurl program I have this
QCMDEXC('STRPCCMD PCCMD(''rundll32 url,FileProtocolHandler '
+ 'http://rgt:8014/rgcgip/redir?' + %char(Key)
+ ''') PAUSE(*NO)' : 200);

When I run the OPENURL command I get page not found, but it doesn't
appear to ever call the REDIR program.

I can provide the configuration file if needed. Maybe I need another
http instance for this.

This is probably really simple, but I don't know what I'm doing wrong

Ideas?

Thanks

MIke
NOTICE: This message, including any attachment, is intended as a
confidential and privileged communication. If you have received this
message in error, or are not the named recipient(s), please
immediately notify the sender and delete this message.
--


This email is confidential, intended only for the named recipient(s)
above and may contain information that is privileged. If you have
received this message in error or are not the named recipient(s),
please notify the sender immediately and delete this email message
from your computer as any and all unauthorized distribution or use of
this message is strictly prohibited. Thank you.
--
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing
list To post a message email: MIDRANGE-L@xxxxxxxxxxxx To subscribe,
unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/midrange-l
or email: MIDRANGE-L-request@xxxxxxxxxxxx Before posting, please take
a moment to review the archives at
http://archive.midrange.com/midrange-l.

NOTICE: This message, including any attachment, is intended as a
confidential and privileged communication. If you have received this
message in error, or are not the named recipient(s), please
immediately notify the sender and delete this message.
--
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing
list To post a message email: MIDRANGE-L@xxxxxxxxxxxx To subscribe,
unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/midrange-l
or email: MIDRANGE-L-request@xxxxxxxxxxxx Before posting, please take
a moment to review the archives at
http://archive.midrange.com/midrange-l.


--
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing
list To post a message email: MIDRANGE-L@xxxxxxxxxxxx To subscribe,
unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/midrange-l
or email: MIDRANGE-L-request@xxxxxxxxxxxx Before posting, please take a
moment to review the archives at http://archive.midrange.com/midrange-l.

NOTICE: This message, including any attachment, is intended as a
confidential and privileged communication. If you have received this
message in error, or are not the named recipient(s), please immediately
notify the sender and delete this message.
--
This is the Midrange Systems Technical Discussion (MIDRANGE-L) mailing list
To post a message email: MIDRANGE-L@xxxxxxxxxxxx
To subscribe, unsubscribe, or change list options,
visit: http://lists.midrange.com/mailman/listinfo/midrange-l
or email: MIDRANGE-L-request@xxxxxxxxxxxx
Before posting, please take a moment to review the archives
at http://archive.midrange.com/midrange-l.







Return to Archive home page | Return to MIDRANGE.COM home page

This mailing list archive is Copyright 1997-2014 by MIDRANGE dot COM and David Gibbs as a compilation work. Use of the archive is restricted to research of a business or technical nature. Any other uses are prohibited. Full details are available here. If you have questions about this, please contact